Of course, a demo reel is all about the animation. But that being equal between animators, which do you think will get the extra point in the end?
WE’VE COVERED A LOT about animating in Maya throughout this book, but to close it out let’s learn some basic lighting and rendering. Since this book is by an animator for animators, we’re not talking about feature film quality lighting; that’s something covered by many great lighting artists in their respective tomes. What we want to gain is some skill in simple lighting techniques that will add a nice bit of polish to our animations. These are very simple and easy tricks that give good results, and look much nicer than simple playblasts for showing your work. When your animation is done, the cheats you learn here will give you a soft, clean, simple look for a demo reel or portfolio that looks nice and doesn’t distract from the animation. All the renders you see in this book have been done using the techniques from this chapter.
FOR THE LIGHTING TECHNIQUES we're going to learn, we need to know a little bit about materials in Maya and how they work. Materials are the attributes you apply to an object that tell the renderer how it should respond to light. They determine the object's color, how shiny it is, if it looks smooth or rough, anything that describes how it looks when lit and rendered. While the possibilities are truly endless, we're only going to worry about a couple of them. For the simple, clean looks we're creating, we don't need to do much more than pick a color and maybe a bit of shininess. Just those few can create quite a bit of depth. We'll also go over a few tricks that will have you experimenting with ease.

This is a basic introduction to materials, and predominantly centers around quickly adding some nice color to our animations, as texturing is outside the scope of this book. But even if you're familiar with Maya's materials, the IPR (Interactive Photorealistic Renderer) feature that we'll talk about is a great cheat in speeding up your workflow. Things are about to get much more colorful.

Open materials.ma and select the shotCam. We have the Goon in a simple pose and the default gray Lambert material all around (yawn).

double clicking on the material is a quick way to rename it, which is necessary when you'll have lots of materials. Name it “goonShader.”
Go to Window > Rendering Editors > Hypershade to open Maya’s Material Editor. The left column is the various materials available to create, the upper section is the materials currently in the scene, and below is the work area for editing materials.

Lambert materials have no specular highlights so are good for the soft clay-looking style we’ll learn later. Lambert1 is the default material in every new scene. Create another one by simply clicking on Lambert in the left column.

Double clicking on the material brings up the Attribute Editor for the material. Click on the box next to Color to bring up the Color Chooser. Choose an appealing color and click Accept.

There are a couple of quick ways to apply the material to the character’s geometry. You can MM click and drag the material from the hypershade onto the part you want to color...
Everything about the material in the viewport is very approximate. You need to render to see what it truly looks like. Click the Render button at the top (Movie Clapboard icon) and you'll see what the color really is.

One very useful tool for speeding up the coloring process is using Maya’s IPR render, which is a real-time render that updates as you change material attributes. Click the IPR button, and then select the area with the character to update.
You need to make a new material for every color you want. You can also create the material, apply it when it’s default gray, and then choose the color. This will let you see the color on the character as it updates in the viewport.

Blinn materials have a specular highlight, which can make them look shiny and more metallic (among other things). Take a material that’s applied to the entire character and in its attributes change the Type to Blinn. He will look shiny in the viewport, although this is very rough and approximate.

Now you can adjust the material attributes and Maya will update the render as you do, giving you instant feedback on what the material actually looks like.

You can even MM drag a material from the Hypershade onto Geometry in the IPR render and it will change the material automatically. Continue experimenting with the Lambert and Blinn materials and their attributes to learn more about them.

HOT TIP
The IPR feature only works with the Maya Software renderer, and certain attributes, like Reflectivity, aren’t shown.
NOW THAT WE HAVE some basic material skills at our disposal, let's learn a popular rendering style for animation tests. This style has an infinite ground plane (no horizon) and shadows to indicate the ground level and give a point of reference to the animation's weight. It works really well for physical tests, such as walk cycles and fight sequences, much like you would see on a game animator's reel. We'll add a simple 3-point lighting scheme, give it some color, tweak the shadows, and we're good to go.

The lights we'll use are called Directional lights. They're infinite lights, in that they have no beginning and no end. In other words, it doesn't matter where we put them in the scene, it only matters which direction they're pointing. Directional lights are often used for things like sunlight, where we don't see where the light starts or ends, and it covers the entire visible area. This makes them perfect for this "infinite ground" plane we'll create.

For the ground we'll use what's called a Use Background material. This material is invisible, but can still have shadows cast on it. We simply see the color that's behind it, kind of like glass, which makes it look like there's no horizon line.

1. Open shadows.ma where we have the character doing a walk cycle in place. The first thing we need to do is create the ground plane. In the Polygons menu set (press the F3 key) go to Create > Polygon Primitives > Plane.

4. Select the camera and in the Attribute Editor, scroll down to the Environment tab. Here you'll find a Background Color Attribute. Select a color you like. I went with a light gray. Render the frame to make sure you're happy with the look.
The plane will be hidden under his foot, so press for the Scale tool and scale up the plane.

In the Hypershade create a Use Background shader and apply it to the plane.

To add the lights go to Create > Lights > Directional Light. Remember that only the rotation of the light affects it, so feel free to scale up and move it to make it easier to see.

This first light is the key light, or main light. It will be the main light falling onto the character, so position it as a good overall light. This is a great time to use the IPR render to tweak the light’s rotation. Ignore the black ground while using IPR, as it doesn’t work on the Use Background material or shadows. Just focus on the character and how this main light will fall on him.

HOT TIP
When you render without having created any lights, Maya uses a default light setup that doesn’t cast any shadows and isn’t editable. Once there is a light present, the default light is not used.
Rendering with Shadows (con.)

7 Select the light and duplicate it by pressing Ctrl-D. The character will turn white from the brightness, as there's double the illumination now. Move this second light to an easy position to rotate it.

8 This is the fill light, so it only needs to be a fraction as bright as the key light. With the second light selected, go into the attributes and turn the intensity down to .25. Also uncheck Emit Specular so only the key light creates the little white highlights.

10 Duplicate the fill light and have it fill in the dark patches on his back. I raised the intensity of this light some to .6 or so.

11 In the first light's attributes, check Use Depth Map Shadows. Increase the Resolution for 1024, make the shadow color not completely black, and set the Filter Size to 3. This creates a softer edge around the shadows.
Position the fill light where it's filling in the side that's not facing the key light. We want to brighten up some of the darker areas, but not so much where it's all lit the same.

IPR doesn't work with the shadows, so you'll need to do a normal render to see it. Continue to tweak the light placement until you're happy with it and the shadow position. We'll render all the frames in the next cheat!
OUR ANIMATION IS READY to be rendered, so we need to adjust the render settings appropriately. Taking a moment to specify how you want the renders created will keep things predictable and organized. You may be rendering an animation that has hundreds of frames, and that means hundreds of image files being created. Rerendering all those frames over and over is not part of the how-to-cheat philosophy!

As you’ve surely deduced, we’re going to be rendering each frame as an image, rather than creating a movie. A movie might seem easier at first, but it actually limits you in a lot of ways. A movie must be completely rerendered every time you make a change. You may render and see a few frames you want to tweak. With separate images, you can simply rerender the frames you changed.

A movie also offers less flexibility for post-production. Using still images, you can render all elements separately in Maya (shadows, highlights, color, etc.) and bring them into a compositing package for the ultimate control of how everything looks.

1. Open shadowRender.ma and click on the Render Settings button. At the top make sure you’re rendering the master layer and using the Maya Software renderer.

2. Check the Path for the images, and make sure it is the images folder for the current project. If not, close the Render Settings, and go to File > Project > Set... and choose the Lighting_Rendering project folder.

8. You’re ready to batch render! Press F6 to switch to the Rendering menu set. Then go to Render > Batch Render. The speed will vary depending on your machine, but this simple animation shouldn’t take more than several minutes. Go grab a soda!
Maya comes with a program called FCheck to view your images as an animation. Run FCheck, go to File > Open Animation, and select any one of the image files you created. It will automatically sequence all of them and play the animation.

Set the frame padding to 3. You always want to set this to one higher than the highest amount of digits in the frames you’re rendering. In this case, it’s 2 digits as we have 24 frames. This puts a zero at the beginning. Sometimes other software can get confused by the frame numbering, but the preceding zero will prevent this.

For the File Output, set the name to walkCycle and we’ll use jpegs for the image format.

Under Frame/Animation extension, set it to name.#.ext. This will name each image walkCycle.framenumber.jpg. At the top under Path you’ll see File name, which indicates how Maya will currently name each file.

Set the frame range from 1 to 24 to render all the frames in this animation. This is where you can tell Maya to only render a few frames if you’ve tweaked something after rendering. “By frame” means you could set it to 2 and render every other frame, or whatever you like.

Make sure you’re rendering the perspective camera. The camera to render is easy to forget, and there’s nothing more annoying than accidentally rendering the wrong one! The image size, 640x480 is fine for this exercise. Close the render settings dialog.

HOT TIP
You can also open an image sequence in Quicktime by going to Open, selecting one of the image files, and checking the Open as Image Sequence box in the dialogue box.
A NOTHER SIMPLE YET APPEALING style for rendering your animation tests is a clay-style render. It’s good for a soft, flat, simple look that doesn’t distract from the animation like poor lighting and texturing will. Again, we’re not talking about doing full-fledged lighting here; these techniques are geared towards simple colors that look nicer than playblasts, are easy to do, and stay out of the way of the animation. All the rendered poses of the Goon character throughout the book were done with this technique.

To create this style of render, we just need to use Lambert materials, and the mental ray renderer in Maya. No lights are necessary, which makes this technique very easy and straightforward. We’ll use a feature of mental ray called Final Gather. What this does is actually use the color of the background as a light source, like a giant, infinite sky surrounding your animation. Also known as indirect illumination, it doesn’t create defined shadows, so I find it works best with non-physical, non-full body tests. In other words, perfect for dialog and acting tests.

Open clayRender.ma for a simple pose of the Goon drinking tea. The materials are Lamberts, one for his body, the other for the cup. Feel free to adjust the colors if you like.

Select the shotCam and open the Attribute Editor. Under Environment select a nice, light color. This color is the light source and will cast a colored light onto the character.
We need to make sure mental ray is loaded and available as a renderer. Go to Window > Settings/Preferences > Plug-in Manager. Scroll down and make sure "Mayatomr.mll" is checked under Loaded. If it already is, you’re good to go.

Open the Render Settings and for Render Using select mental ray. Then click on the Indirect Lighting tab and scroll down to Final Gathering. Check the box to enable it and set the Accuracy to 300. Higher accuracy creates smoother results but takes longer to render.

Render the scene and you’ll get a nice, soft, appealing render that took about 30 seconds to do!

Experiment with different background colors and Lambert materials. For instance, making the character light gray will create a nice monochromatic look, as the light color influences the Lamberts.

HOT TIP
If you’re using a ground plane with this technique, don’t forget to put a Use Background Material on it to make it invisible, yet still bounce light.
EVERY ANIMATOR KNOWS WHAT IT’S LIKE to get that “fire in your belly” feeling. After seeing something that you found so cool and awesome, you want nothing more than to run to your computer and create something just like it. Whether it’s a film, book, TV show, piece of art, etc., inspiration can come from many sources. As an artist, we can fall into a rut where we forget what made us want to animate in the first place. Experience is a catalyst for growth, but it can also erode the wide-eyed wonderment you had when you first saw that special film or show that made you say “I want to do THAT!” But staying inspired isn’t difficult; it’s just something that needs some attention every once in awhile. If creating is starting to feel commonplace and uninspired (and it happens to everyone at some point), then perhaps seeking out some of the following will help rekindle the flame:

**Top 10**

Everyone has a top ten list of favorite animated films. When’s the last time you watched one? What was it about them that made you so excited to animate? The films and TV shows that define the art form for you should never be more than an arm’s length away from your desk.

**Films**

Any film, from animated to live action to everything in between, can serve to inspire your creative flow. It’s true that many animated films are made for a specific audience range, but many animators fantasize about creating work outside the typical family scope. Documentaries, art films, sci-fi epics, slasher movies, anything outside the box for animation can give you new ideas and things to try. Looking beyond genre, perhaps it’s the way a film was shot that inspires new staging and composition ideas, or how it uses a soundtrack. Leave no film-related discipline unturned when searching for something unique.
Other Art Forms
Move away from the time-based visual element we work in. Books, music, museums, graphic design, theater, any creative discipline can give you ideas that can make for refreshing animation work. Different mediums engage your brain in different ways. If you haven’t been reading much, you may find that a book opens some new doors for you or that listening to some music you’re unfamiliar with gives you visual ideas you wouldn’t have had otherwise.

Process
You can be inspired by a particular artistic process or challenge. Never did stop motion? Set up your digital camera, grab some action figures, and give it a try! Create interesting limitations and see if you can meet their challenges. Can you make a simple ball rig emoter? Make a cool animated gif with photographs from your family reunion? Animate only characters in the wingding font and tell a story? Anything that pushes you out of your comfort zone or initially seems unreasonable is great process fodder.

Other Artists
With the multitude of blogs, websites, artist sketchbooks, “Art of” books, interviews, DVD extras, and more, we have more information and inspiration available to us than any past society. Make use of it! Having an hour set aside each week to seek out new things you haven’t heard of is a wise idea. You can watch shorts on YouTube, read blogs, look through artist websites and communities, photographs, watch other reels, anything that shows you what everybody else is doing. Keep a folder or hard drive that functions as your personal inspiration library, and archive anything you find that you like. When you’re not feeling your work, start browsing through your library and see where it leads you.

These are just a few of the ways you can keep your creative desire fresh and always hungry for more. Maintain a steady flow of inspiration, and you’ll never tire of challenging yourself and becoming a better artist. And who knows, you just may come up with the thing that inspires everyone else to keep on going. Best of luck, and happy animating!